Intermittent Dash Notify Issue Affecting Numbers and Templates
Minor incident
Dash Notify
Website
SMS
MMS
2026-03-26 04:34 PM EDT
· 2 hours, 13 minutes
Updates
Resolved
March 26, 2026 · 05:50 PM EDT
A fix has been implemented.
Please don’t hesitate to reach out to support at help@esendex.us if you require further assistance.
Investigating
March 26, 2026 · 04:34 PM EDT
We are investigating an intermittent issue affecting Dash Notify customers.
The issue is affecting multiple features on the Dash Notify platform including but nit limited to: selecting a number when creating a message and message templates to fail to load.
Refreshing or clearing the browser cache and cookies can resolve the issue in some cases.
Please don’t hesitate to reach out to help@esendex.us for further information or to report a new issue.
← Back
US Platform Status