Service Degradation - Monitoring
Major incident
SMS Notify V2
Binds
SMS
API
MMS
DLR
Postbacks/Webhooks
Dash Notify
Website
Binds
SMS
API
MMS
DLR
Postbacks/Webhooks
Phone Notify
PTSN
Bridge
Inbound
Outbound
Numbers Service
Website
Postbacks/Webhooks
Phone Verify API
PAV API
Client Admin portal
2025-11-18 06:35 AM EST
· 3 hours, 47 minutes
Updates
Resolved
November 18, 2025 · 10:21 AM EST
Should you have any questions, please contact your account manager or contact our support team.
Monitoring
November 18, 2025 · 10:18 AM EST
We were made aware of an outage affecting the Esendex US services, this is due to the Cloudflare Global Network experiencing issues.
We have received an update from Cloudflare:
Monitoring - A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Nov 18, 2025 - 14:42 UTC
Our internal team will continue to monitor the situation.
← Back
US Platform Status